Monday, September 13, 2010

Slony-I error TIPs

分享一下在裝Slony-I時遇到的問題與解法,有些權限問題就沒寫了。


Error message :
Error: require EVENT NODE
Error: No admin conninfo provided for node -1

Fix :
Modify

store node ( id=2, comment='Slave Node');

to

store node ( id=2, comment='Slave Node',event node=1 );




Error message :

Error: language PL/pgSQL is not installed in database 'dbname=test host=192.168.0.1 user=postgres port=5432'

Fix :
Use command "createlang" install a procedural language into a PostgreSQL database.

Usage:
createlang [OPTION]... LANGNAME [DBNAME]
Like this
$ createlang -d testdb plpgsql

No comments:

Post a Comment

Related Posts Plugin for WordPress, Blogger...